This topic contains 10 replies, has 2 voices, and was last updated by dimoveli 1 year, 6 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #4564

    dimoveli
    Member

    Έχω παραλάβει το hydrobot sensor v2 και έκανα όλες τις απαραίτητες συνδέσεις. Δυστυχώς όταν ανοίγω την σειριακή οθόνη υπάρχουν τα εξής  προβλήματα:

    1) παρά το γεγονός ότι έχω τοποθετήσει sd κάρτα,  δεν την αναγνωρίζει. (έχω αλλάξει και κάρτα και αντάπτορα αλλά συνεχίζει να μην μπορεί να την αναγνωρίσει)(Δεν έχει προστασία εγγραφής)

    2) μου δείχνει σαν τάση μπαταρίας 1,3 volt!!, Η μπαταρία είναι καινούργια και είναι στα 3volt!! Είτε συνδέσω την 9βολτη μπαταρία είτε όχι, οι ενδείξεις είναι ίδιες

    Τι λάθος έχω κάνει;

    Σημείωση: Στο πρόγραμμα του hydrobot λαμβάνω κανονικά μετρήσεις και μπορώ να τις αποθηκεύσω στον Η/Υ αλλά όχι στην κάρτα.

    #4574
    dpiperidis
    dpiperidis
    Member

    Δεδομένου ότι έχετε κατεβάσει το πρόγραμμα από εδώ, κάτι συμβαίνει με το είδος της κάρτας που τοποθετείτε. Προτιμήστε μια micro SD των 4GB, με τη βοήθεια του κατάλληλου αντάπτορα (που πολλές φορές συνοδεύει την κάρτα)

    Η τάση της μπαταρίας που βλέπετε στο πρόγραμμα δεν έχει σχέση με την μπαταρία που βάζετε στο shield. Κανονικά δείχνει την τάση της μπαταρίας που τροφοδοτεί όλο το κύκλωμα (για την δική σας περίπτωση η 9V μπαταρία).
    Ωστόσο εξ ορισμού η τιμή δεν είναι έγκυρη, αφού τίποτα δεν έχει συνδεθεί στην κατάλληλη θύρα που μετράει την τάση της μπαταρίας (η αναλογική θύρα A0). Σε ΚΑΜΙΑ περίπτωση μη συνδέσετε απ” ευθείας την τάση της μπαταρίας στην εν λόγω θύρα. Διαβάστε τη σημείωση στο προηγούμενο link για λεπτομέρειες…
    Αυτό είναι και μια προαιρετική άσκηση/πρόκληση που θα μπορούσε να τεθεί στα παιδιά (φυσικά με το κατάλληλο θεωρητικό υπόβαθρο).
    ΜΗΝ κάνετε τίποτα αν δεν είστε σίγουρος… Αν για οποιονδήποτε λόγο δεν είστε σίγουρος, αγνοήστε αυτήν την ένδειξη.

    Ευχαριστούμε
    Χρόνια πολλά και καλή χρονιά!

    • This reply was modified 1 year, 11 months ago by dpiperidis.
    #4580

    dimoveli
    Member

    Έχω κατεβάσει το σωστό πρόγραμμα. Οι κάρτες που χρησιμοποήσα είναι μια ScanDisk 8GB και μια ακόμα 16 GB iόλες κατ  10.

    Θα αγοράσω μια 4GB …

    Καλή χρονιά

    #4588
    dpiperidis
    dpiperidis
    Member

    Επίσης βεβαιωθείτε ότι διαμορφώσατε την κάρτα σε FAT32 (format)
    Αν είναι σε NTFS δε θα δουλεύει

    #4620

    dimoveli
    Member

    Η διαμόρφωση είναι FAT32. Δυστυχώς η μόνη 4 GB  που βρήκα κοστίζει ~9€ και δεν θα την αγοράσω.

    έρχονται και τα υλικά που αγόρασα από ebay οπότε  έχω τις παρακάτω ερωτήσεις:

    1) Σκέφτομαι να κόψω ένα usb και να το συνδέσω με το utp του hydrobot. Αν οι συνδέσεις γίνουν σωστά θα δουλέψει;

    2) Οι ρυθμιστές των κινητήρων μπορούν να συνδεθούν πάνω στην πλακέτα της κάρτας sd ή σε ξεχωριστή;

    Με την παραπάνω συνδεσμολογία θα χρειαστώ 4 καλώδια για το usb, 2 για την τροφοδοσία? των κινητήρων και 2 για μεταφορά εικόνας από κάμερα rca. Προβληματίζομαι για την διατομή των καλωδίων αν αρκεί ένα ζεύγος ή θα χρειαστεί να δεσμέυσω και το δεύτερο.?!

    Έχω και τον αισθητήρα PH , οπότε θα σας στείλω φωτογραφίες και τον τύπο του για να δούμε αν είνια δυνατόν να τον χρησιμοποιήσουμε ως επιπλέον αισθητήρα!

     

     

    #4621

    dimoveli
    Member

    <span style=»color: #5c5c5c; font-family: Arimo, Arial, “Liberation Sans’, FreeSans, sans-serif; font-size: 12px; background-color: #fbfbfb;»>1) Σκέφτομαι να κόψω ένα usb και να το συνδέσω με το utp του hydrobot. Αν οι συνδέσεις γίνουν σωστά θα δουλέψει;</span>

    Απάντηση

    ΄΄Εκανα τη σύνδεση και δουλεύει κανονικά. Δεν σύνδεσα τη γείωση του usb και χρησημοποίησα 2 ζεύγη καλωδίων. κατάφερα να μεταφέρω τις μετρήσεις από το arduino στο Η/Υ σε μεγαλύτερη απόσταση από το usb ΚΑΙ έχω 4 καλώδια για τροφοδοσία …

    #4623
    dpiperidis
    dpiperidis
    Member

    Δηλαδή χρησιμοποιήσατε το UTP που έχει 8 συνολικά καλώδια και το συνδέσατε απ ευθείας στο USB του arduino; Χωρίς κάποιον ενισχυτή (υπάρχουν στο εμπόριο) για τις μεγαλύτερες αποστάσεις;
    Ή συνδέσατε τα ΤΧ – RX του arduino;

    • This reply was modified 1 year, 10 months ago by dpiperidis.
    #4681

    dimoveli
    Member

    Έκοψα το καλώδιο USB  και ενδυάμεσα έβαλα επέκταση 10μ UTP. Ήθελα να μπορώ να βγάζω το arduino εκτός κουτιού. Επίσης δεν έψαξα να βρώ ποιό καλώδιο είναι ΤΧ-ΡΧ. Αν συνδέσω τα δύο αυτά καλώδια, μπορώ να τροφοδοτήσω το arduino από τα 12v και να έχω αντί για 2 , 4 ελεύθερα καλώδια;

    #4682

    dimoveli
    Member

    Σημείωση , κατέβασα 4 καλώδια για δεδομένα και 2 για τροφοδοσία κινητήρων.

    #4683

    dimoveli
    Member

    Η πλακέτα SD του arduino είχε πρόβλημα. Αγόρασα καινούργια και δούλεψε, μέχρι που μπήκε στη θάλασσα…

    #4781

    dimoveli
    Member

    Η φετινή κατασκευυή – βελτίωση του hydrobot είχε τα πάνω και τα κάτω της.

    Σαν θετικά στοιχεία μπορώ να πω ότι ήταν η μετατροπή του αναλογικού Hydrobot σε πλήρως ψηφιακά ελεγχόμενο. Έγινε επέκταση του καλωδίου usb του arduino με τη χρήση utp τροφοδοτώντας τους κινητήρες και το arduino με 12v. Οι κινητήρες συνδέθηκαν με Hbridge. Κατασκευάσαμε μια γέφυρα με τα χαρακτηριστικά των οδηγιών (αγοράσαμε από κινα τα τρανζιστορ) αλλά η κατασκευή ήταν ογκώδης. Χρησιμοποιήσαμε ετοιμες γέφυρες για να χωρέσουνε στο κουτί.

    Τοποθετήσαμε arduino, sensors, h-bridge στο κουτί, το στεγανοποιήσαμε, το δέσαμε και ρίξαμε το hydrobot στο νερό. Δυστυχώς του κουτί δεν στεγανοποιήθηκε και πήρε νερό…

    Το νέο έτος θα αλλάξουμε του arduino uno με arduino nano, για εξοικονόμηση χώρου, αγοράσαμε sd module για το nano. όλες οι συνδέσεις θα γίνουν με κόλληση και το utp θα συνδεθεί πάνω στις TX RX . Θα προσπαθήσουμε να αλλάξουμε τον τρόπο βύθισης του hydrobot.

    Θα τα ξαναπούμε την επόμενη σχολική χρονιά…

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.